Mac下安装ruby环境

1、环境要求

系统:Mac OS X

2、安装依赖

2.1 安装 Xcode

Mac下的开发环境,首先需要安装Xcode,Xcode里面集成了很多开发工具。打开App Store,右上角输入Xcode。

2.2 安装Homebrew

Homebrew是Mac系统汇总很方便安装软件的一个命令行工具。这里只介绍安装步骤。

1、在命令行输入以下命令。

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

2.3 安装rvm

rvm是用来管理不同版本的ruby,推荐它是因为使用很简单,至于为什么不用Xcode安装好以后系统自带的ruby,原因是系统自带的ruby版本太老。大家在学习ruby代码的时候,可能会遇到新版本的方法或者语法,老版本还不支持的问题。

接着在刚刚的终端里面依次输入下面3行:

brew install gpg # linux用户不需要执行本行
gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3
curl -sSL https://get.rvm.io | bash -s stable

如果最后一行安装过程失败,可以执行下面这行:

curl -L https://raw.githubusercontent.com/wayneeseguin/rvm/master/binscripts/rvm-installer | bash -s stable

安装好以后执行:

rvm -v

会得到类似下面的提示:

rvm 1.29.1 (latest) by Michal Papis, Piotr Kuczynski, Wayne E. Seguin [https://rvm.io/]

3、安装ruby

输入下面2行:

rvm requirements
rvm install 2.3.2 # 安装2.3.2版本,如果大家材料指定版本,可以把2.2.3 设为教材的版本号

随着漫长的安装等待以后,会提示安装成功。可以通过输入下面命令检查是否安装成功。

ruby -v

4、升级ruby版本

4.1 查看当前ruby版本

ruby -v

4.2 列出已知的ruby版本

rvm list known

4.3 安装最新版本的ruby(这里是2.4.1版本)

rvm install 2.4.1

4.4 安装完成后再执行 rvm -v 查看是否安装成功。

发表评论

电子邮件地址不会被公开。 必填项已用*标注